Ortam Geçit Kontrol Protokolü (Media Gateway Control Protocol), IP üzerinden Ortam Geçitleri ve Public Switched Telephone Network PSTN kontrolü için geliştirilen bir uygulamadır. Temel mimari ve programlama arayüzü RFC 2805'te tanımlanmıştır ve günümüzde MGCP RFC 3435'te tanımlanmıştır. MGCP Voice over IP (VoIP) içinde bir sinyal ve çağrı kontrol protokolüdür. MGCP, arama aracını (Call Agent) ve ortam geçit denetçilerini (MGC) tanımlar, harici olarak çoklu servis paket ağlarının uçlarında yerleşik bulunan ortam ses iletim-akış cihazlarını veya ortam geçitlerini denetlemelerine olanak sağlar. Ses akış işlemleri ve çağrı denetim işlemlerinin ayrılması ortam geçidinin işletimini basitleştirmektedir. MGCP oturum kurulmadan önce IP uç noktaları arasında port tahsisi ve codec seçimi için Session Description Protocol (SDP) ve medya akımlarının çerçevelenmesi için Real-time Transport Protocol (RTP) kullanır.
Mimarisi
Arama aracı (ya da Ortam Geçiti Denetçi),en az bir tane Ortam Geçidi, en az bir tane sinyal verme geçidin'den oluşur. Ortam Geçidi: Paketler ve devreler arasında ortam sinyallerinin dönüşümünü yapar. Sinyal Verme Geçidi: PSTN'e bağlanmayı sağlar. Arama aracı Ortam Geçidi'ne haber vermek için MGCP'yi kullanır:
- Neler arama aracında rapor edilmiş olabilir?
- Uç noktalar birbirlerine nasıl bağlanmış?
- Hangi sinyaller uç nokta üzerinde çalışmış?
MGCP ayrıca Arama aracına Ortam Geçidi üzerindeki uç noktaların akım durumlarının denetimi için izin verir. Ortam Geçidi olayları(telefonun açık konumu, rakamları tuşlamak) arama aracına raporlamak için MGCP'yi kullanır. Her yayınlanmış MGCP komutu bir iş Id'sine sahiptir ve bir yanıt alır.
Ortam Geçit Kontrol Protokolü'nün Gelişimi
MGCP Protokolü SGCP, IPDC protokollerinin sonucunda oluşturulmuştur. IETF MEGACO Working Group Ortam Geçidi ve Ortam Geçidi Denetçisi arasında ilk arayüz çözümü olarak MGCP version 0.1 i çıkarmışlardır. MGCP çalışmalar sonucunda Ekim 99 5. version ile birlikte RFC 2705 şekline dönüştürülmüştür.
Ortam Geçit Kontrol Protokolü Komutları
CRCX
Bağlantı Oluşturulması: İki uç nokta arasında bağlantının oluşturulması.
DLCX
Bağlantı Sonlandırılması: Bağlantının sonlandırılması ve bağlantının devam ettiği süre içindeki istatistiklerin toplanması.
MDCX
Bağlantının Değiştirilmesi: Bağlantının özelliklerinin değiştirilmesi.
NTFY
Haber Verme: Ortam geçidi denetçisi gözlenen olaylar oluştuğu zaman bilgi verir.
AUEP
Uç Nokta Denetimi: Bir uç noktanın durumu ile ilgili karar verir.
RQNT
Bildirim İçin İstekte Bulunmak: Bir uç noktadaki önceden tanımlanmış olaylarda istek göndermek için ortam geçitine istekte bulunur.
AUCX
Bağlantı Denetimi: Bağlantı ile ilgili parametreleri düzeltmek.
